Home Forums SpyroPress Themes Pifour Bootstrap breaks using latest jQuery

Viewing 1 reply thread
  • Author
    Posts
    • #93650

      Tomek Wojcik
      Participant

      Hi there,

      I think this theme does not work with latest jQuery. Dev tools console returns: “Uncaught Error: Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3”

      The issue I was trying to resolve was that the mobile burger menu was not working.

      As a temporary fix I tried adding the jQuery migrate helper plugin, that didn’t work. I tried downgrading jQuery to 2.2.4 (the latest version before 3) which resolved the menu but broke Slider Revolution.

      I thought I would turn to the demo at http://demo.spyropress.com/themeforest/cargo-pifour/ for inspiration but it is using jQuery v1.12.4 and a versions of Slider Revolution from early 2019.

      I don’t know if it’s broken anything else but calling Bootstrap 4 JS from a CDN appears to have resolved the menu issue and not break a more recent version of the slider.

      Might you be working on an update to the theme? Perhaps there is something I am missing?

      Thanks,

      Tomek

    • #93668

      Maria Do
      Keymaster

      Hello there

      Thank you for contact us here.

      Please send the following information to get the support faster:

      – FTP’s information
      – Site’s URL
      – WordPress admin account
      – License certificate image:http://prntscr.com/o8tck1(to ensure you have bought the theme and deserve the good support).

      don’t forget make private for any information.
      Regards!

Viewing 1 reply thread
  • You must be logged in to reply to this topic.